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Batch Conversion 

Introduction 
 
Batch Convert is a utility that was first delivered with MicroStation V8 
(08.00.01.xx). It is an application that may be used to convert individual files, 
groups of files, or entire folders of files from any of the supported design formats 
to any supported format (DGN, DWG, and DXF). 
 
Currently the supported formats include the MicroStation V7, MicroStation V8, 
MicroStation cell libraries, AutoCAD DWG, AutoCAD DXF (AutoCAD 11/12 – 
2007/2008 DWG files) IGES, STEP, CGM, XMT, SAT, and XTL formats. 
 
The conversion process may be performed using the files as they were created 
or by applying remapping “rules” to control conversion of levels, fonts, linestyles, 
colors, or weights in any combination. The remapping environment provides a 
robust set of criteria that may be used to govern how the remapping is applied to 
the elements in the source file. With remapping applied to a conversion, the user 
can control the attributes of the elements in the output file. 
 
This session will guide you through the usage of the Batch Convert utility, 
including remapping, to control the conversion from one CAD format to another. 
You will learn more about: 
 

• How to invoke the Batch Convert utility 
 

• Set up the Batch Convert job 
 

• Save / Recall a Batch Convert Job file 
 

• Batch Convert Log File 
 

• Processing the Batch Convert job 
 

• Apply Batch Convert options to control element attributes 
 

• Run the Batch Convert utility from a Command Prompt 
 

• Use Batch Convert to apply “your” CAD standards 
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The MicroStation V8 Batch Conversion Utility 
Batch Convert is located on the Utilities pulldown menu. To start the Batch 
Convert application, select Utilities > Batch Converter from MicroStation’s Main 
Menu. 
 

 
 
 
Setting up a Batch Conversion 
The following will guide you through setting up a Batch Convert Job. 
 

1. The first step in using the Batch Convert utility is to set up a Batch 
Conversion Job. The Default Output Format is selected along with a 
Default Destination folder. If the folder does not exist, it will be created 
when the Batch Convert job is processed. 

 
2. Next the conversion tasks are selected by clicking on the Add Files or 

Directories icon. This will open a file selection dialog. 
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Select the files desired and click the Add button. When the desired list for 
conversion has been created, click the Done button to return to the Batch 
Convert dialog. 
 

3. If desired, the Source, To, or Destination may be modified. This includes 
adding a standard file filter. 
 
For example, if you wanted to convert all the files in the directory and its 
subdirectories, the source column entry would read: 
 

d:\prj007625\*\ 
 
If you want to convert all the files with the extension .ROW from directory 
d:\prj007625\ and its subdirectories, the source column entry would read: 
 

d:\prj007625\*\*.row 
 
 

Notes on the use of Batch Convert: 
• Different rows can have different output formats and destination 

directories.  
• The order of conversion is indicated by the sequence number column 

(which has the heading "#").  
• Rows can be removed from the conversion table using either the 

Remove Conversion selection in the Edit menu, or the Remove icon.  
• Conversions can be sorted by any of the columns, but the Edit menu 

options that modify the order are enabled only when sorting by the "#" 
column in ascending order.  

• If DWG or DXF files are involved as source files, the settings accessed 
through the DWG Open Options selection on the Edit menu are used.  

• If any files are to be output in those formats, the settings accessed 
through the DWG Save Options selection on the Edit menu are used.  

• The Log file Options selection on the Edit menu is used to set a log file 
and to specify whether it should be emptied prior to conversion 
processing. 

 
 
Saving and recalling Batch Convert jobs  
If you plan to perform file format conversions more than once, you should 
consider saving your batch convert setup as a "job." To do this, click the Save 
Batch Convert Job icon or select the Save option from the File menu. The default 
extension for batch conversion job files is .bcnv. Once you have saved a batch 
conversion job, you can recall it by clicking on the Open Batch Convert Job icon 
or selecting Open from the File menu. The DWG open and save options, the log 
file name and all conversion tasks are saved to the batch conversion job file. The 
batch conversion job file is a text file similar to Windows initialization files and can 
be edited with a text editor, if desired. 
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Note: 
If you batch convert drawings using similar parameters but with different source 
drawing files, you can save a Batch Convert Job File with the basic parameters 
set up but without any drawings listed. You would then have a Batch Convert 
“seed file” to use when creating new batch conversions. 

 
 
It is also possible to specify multiple formats to save to. This can be set up when 
creating the project. The same Conversion Task (input) may be listed multiple 
times with different Default Output Formats and Default Destination folders. 
 
The multiple selections may be accomplished graphically in the dialog as 
illustrated: 
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or  
 

by editing the Batch Convert Job File (.bcnv) with a text editor. 
 

 
 
 
 
The Batch Convert Log File 
A Batch Convert Log File is a useful tool to track the success of your Batch 
Convert project. The Log file may be configured by selecting Edit > Log File 
Options and selecting a path and file to write to. 
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Processing the Batch Convert job 
When the batch conversion job is set up as desired, the conversion process can 
be started by clicking on the Process Batch Convert Job icon or selecting File > 
Process... from the main menu. If you want to convert only a portion of the job, 
select the rows that are to be processed and turn on the Process Selections Only 
toggle. 
 
When the conversion is started, a dialog appears displaying a list of the files to 
be converted and the progress of the overall conversion job (Figure 4). 
 

 
Notes on Processing Batch Conversion jobs  

• If the source format is the same as the output format, the source file is 
simply copied from the input location to the output directory.  

• When feasible, Batch Convert uses the source file name for the output 
file. When the source is in MicroStation/J or MicroStation V8 format and 
the output is an AutoCAD file, the output extension is automatically set to 
.dwg or .dxf as appropriate. If there are multiple files with the same root 
name (differing only in extension) in the source directory, the extension is 
incorporated into the output file name. This is due to the fact that all 
AutoCAD files must have the .dwg or .dxf extension.  

• Batch Convert checks to see if the output file exists, and, if so, whether it 
is the same date as the source file. If so, it does not bother to convert or 
copy the source file to the output.  

• The file time of the output file is set to match the file time of the input. 
This feature makes it feasible to run the batch conversion application for 
a job frequently, updating the output versions of only those source files 
that have changed. It also makes it possible to restart a batch conversion 
job. When the destination file is up to date, the Status column indicates 
that fact.  

• When the conversion process is started, the Convert button 
automatically changes to "Pause." Clicking Pause directs Batch Convert 
to pause after converting the current file. The button then changes to 
Resume. The application never stops in the middle of converting a file.  

• If MicroStation/J or MicroStation V8 files are being converted to 
AutoCAD files, and the Save References As DWG/DXF toggle in the 
DWG Save Options is turned ON, then the references of each file are 
processed, as well as the master file. In certain instances, this results in 
the automatic conversion of some files that are in the batch conversion 
job before they are reached in the table. In such a case, the Status 
column will change to Already Converted when the batch conversion 
process reaches such a file.  

• When the conversion process is finished, the Convert / Pause / Resume 
button changes to read Done, and the Cancel button is disabled. Clicking 
Done closes the dialog.  

• Clicking the Cancel button stops the batch convert job after the current 
file is finished.  

• As files are converted, the status of the conversion is displayed in the 
Status column, and the time required for the conversion or copy is 
displayed in the Time column.  

• Details about the conversion process are written to the log file. This log 
file can be opened using any text editor, such as Notepad.  
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• When the conversion process ends, the log file table can be sorted by 
any column. In particular, it can be quite useful to sort by the Status or 
Time fields. 

 
 
Apply Batch Convert options to control element attributes 
Batch conversion can be a very useful tool to “simply” convert from one format 
to another, but you may often find that it is necessary to control the conversion 
process. This is the function of Batch Convert Options. Batch Convert Options 
are provided for the following: 
 

 DWG Open Options 
 DWG Save Options 
 V8 Save Options 
 V7 Save Options 

 

 
 
There are many similarities between the different options. In general, you may 
control the mapping of levels, fonts, line styles, colors, line weights, and cell 
names as well as DWG specific settings such as DWG / DXF version, unit 
designation, and a DWG Seed File. 
 
MicroStation V8 uses a Comma Separated Value (CSV) file to control the 
remapping of design graphics. CSV files may be applied to V7, V8, and DWG file 
formats during conversions. A CSV file is a text file with “columns” of information 
where each column is separated by a comma. It is possible to edit CSV files with 
any text editor but Excel is especially handy! When the file is opened with Excel, 
there are macros to make the set up of the remapping easier. The CSV, when 
opened, will look like any other XLS file.  
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When configuring remapping, each remap category will located on separate tabs 
within Excel. The graphical editing environment of Excel simplifies the 
configuration of the remap. 
 

 
 
 
The remapping operations let you change the value of an element parameter in 
the converted by establishing a “search” and a “substitution” when the search 
criteria are met. For example, when configuring levels it is possible to populate 
the values by selecting the button to obtain values from the open drawing file. 
 
 
 
 
 
 
 
 
It is also possible to refine the search by displaying additional “qualifiers” using 
the Show Optional Columns toggle. 
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By refining the search through the use of remapping qualifiers, it is possible to be 
very specific for the item being located. This would allow text or dimensions to be 
manipulated separately from line work that exist on the same level in the input 
file. 
 
The primary keys (level, colors, etc.) as well as the qualifiers and output actions 
also support special values called keywords. Keywords are special values that 
may be used to help control the search for elements. 
 
Some examples of keywords are: 
 

%match 
%bylevel 
%drop 
%unmapped 
 

An example of a keyword used in the remapping environment might be used to 
control converting colors in a V7 DGN to ByLevel color in a V8 DGN. 
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Run the Batch Convert utility from a Command Prompt 
The batch conversion application can be run from a Command Shell. To use 
Batch Convert in this mode, first create and save a batch conversion job in the 
manner described. Next, open a Command Prompt. 
 

Start > Programs > Accessories > Command Prompt 
 
From the Command shell prompt, enter the command: 
 

ustation –wabatchconvert –i[path to Batch Convert Job File.bcnv] 
 

For example: 
 

ustation –wabatchconvert –iC:\Sample_Proj\sample.bcnv 
 
 

 
Use Batch Convert to apply “your” CAD standards 
When converting your drawings, it is possible to apply a remapping environment 
to perform a “standards check” during the conversion. This is accomplished by 
creating a “specs checker” remapping CSV file to look for elements that were 
defined correctly in the input file and pass them through the conversion normally 
while elements that fail the check are moved to a special level or color. 
 
The rules for the “standards check” CSV file may be pulled from your level library 
by exporting the level definitions to a CSV file. This data may then be 
copy/pasted from the level definitions data into the “standards check” CSV file. 
 
This method allows a file to be searched for elements that match (or can match) 
design standards and move those that do not to a combination of attributes 
(level, and/or color, and/or style, and/or weight) to make them easy to isolate and 
deal with. 
 
Remember, the general rule is: garbage in, garbage out (GIGO)! 
 

 
 

 

Remember, Garbage In – Garbage Out! 
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